Service Interruption Discovery
Incident Report for Artera
Resolved
This incident is resolved.
Posted Apr 22, 2021 - 15:05 PDT
Investigating
WELL is current exploring a service interruption affecting staff and admin users. We will update here in 10 minutes.
Posted Apr 22, 2021 - 15:02 PDT
This incident affected: USA - Messaging (Automations and Automated Messaging).