At 7:37 AM PT, our engineering team deployed a code fix that successfully eliminated the high database CPU usage. With this deployment, patient channels in the Artera Inbox are loading normally again and full functionality has been restored.
Impact Note: Automated messaging remained fully operational and continued sending to patients without interruption throughout the incident.
All systems are stable, and this incident is now resolved.
Posted Jul 31, 2026 - 08:41 PDT
Monitoring
Engineering has deployed a fix that successfully resolved the high database CPU utilization. All patient channels in the Artera Inbox are now loading normally, and all systems are online and available.
Our team is actively monitoring performance to ensure full system stability.
Posted Jul 31, 2026 - 07:09 PDT
Update
Our engineering team is currently deploying a fix to resolve the application issues impacting the Artera Inbox.
Current Status:
Working: Automated messages continue to send normally from Artera.
Impacted: Patient channels in the Artera Inbox are still failing to load.
Posted Jul 31, 2026 - 06:58 PDT
Identified
We have identified the cause of the issue impacting the Artera Inbox. A code release at 6:00 AM PT has resulted in high database CPU utilization, preventing patient channels from loading.
Our engineering team is actively working on a fix to resolve the database load and restore full functionality.
Posted Jul 31, 2026 - 06:48 PDT
Investigating
We are currently investigating an issue where the Artera Inbox is failing to load patient channels. Users may see loading spinners or blank screens when trying to open conversations.
Our team is actively looking into the cause, and we will post another update as soon as we have more details.
Posted Jul 31, 2026 - 06:27 PDT
This incident affected: USA - Messaging (Automations and Automated Messaging, Manual Messaging) and USA - Artera Platform (Artera Web Application).